Sävar Turbo Site

Ett forum för motorentusiaster
Aktuellt datum och tid: lör aug 02, 2014 3:25 am

Alla tidsangivelser är UTC + 1 timme




Ny tråd Svara på tråd  [ 5 inlägg ] 
Författare Meddelande
InläggPostat: sön aug 03, 2008 2:40 am 
Offline
Forumsberoende
Användarvisningsbild

Blev medlem: fre jun 30, 2006 5:25 pm
Inlägg: 750
Ort: Sjulsmark
Lämnade garaget något bitter nyss då jag inte lyckats få kontakt med boxen.Förmodligen har jag väl gjort nåt jättedumt. Hursomhelst;

Kör med en USB -> Seriell adapter som denna:
http://www.jula.se/e-Sales/esa/default. ... 0EQ=924237

Var lite tveksam till att jag tolkade VEMS manualens pinout på DB9:an korrekt så efter att inte fått någon kontakt överhuvudtaget gjorde jag en omlödning till såhär:

Bild

Var spegelvänt lött på DB9:an innan. Med den här lödningen så reagerar USB-adaptern och när jag startar megatune så klagar den inte längre över att det inte finns någon kontakt. Men när jag kör testet så får jag ingen kontakt. Jag har kontrollerat och ställt in COM-porten korrekt. Så något är kapitalt fel eller så är jag bara för trött just nu för att inse något uppenbart. Har även stängt av en massa processer som eventuellt skulle kunna störa kommunikationen.

RX/TX stämmer överens med EC18 kontakten, har mätt och mätt och mätt, och det är rätt. Jag trippelkollat jordarna och 12V+ till boxen och den har spänning och jord helt korrekt.

Imorgon blir det försöka få tag på någon ny USB->seriell adapter men annars vet jag inte :( Sista dagen på semestern imorgon också.

Hjälp!

_________________
Projektet | Memberspage på vems.hu


Senast redigerad av Nicklas Eriksson sön aug 03, 2008 9:49 pm, redigerad totalt 1 gång.

Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: sön aug 03, 2008 9:17 am 
Offline
Forumsberoende
Användarvisningsbild

Blev medlem: fre jun 30, 2006 5:25 pm
Inlägg: 750
Ort: Sjulsmark
Har listat ut att jag i nuvarande utförande (bilden) har kopplat fel



Detta enligt sista bilden på:

http://megasquirtavr.sourceforge.net/ma ... tml#Config

och denna pinout:

Bild

Så just nu är kontakten (felaktigt) lödd:
Pin 1 -> Jord
Pin 3 -> TD
Pin 4 -> RD

Och det märkliga är ju att USB-adaptern reagerar (blinkar och har sig) i det felaktiga utförandet. Måste nog hitta mig en ny.

btw, fick ett mail att någon hade postat i den här tråden men det visade sig vara fel?

_________________
Projektet | Memberspage på vems.hu


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: sön aug 03, 2008 5:10 pm 
Offline
Forumsberoende

Blev medlem: tis mar 15, 2005 7:44 pm
Inlägg: 678
Ort: Arvidsjaur
det har inte funkat för mig heller med en sån där usb adapter. men med en vanlig db9 förlängningskabel funkade allt klockrent. Men du kanske inte har någon sådan utgång på datorn.


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: sön aug 03, 2008 9:46 pm 
Offline
Forumsberoende
Användarvisningsbild

Blev medlem: fre jun 30, 2006 5:25 pm
Inlägg: 750
Ort: Sjulsmark
Nä, jag har tyvärr inga com portar på min dator. Vilket ju hade varit mycket trevlig såna här dagar, men annars har man ju inte använt en sån på säkert 10 år.

Idag har jag laddat hem nya drivrutiner från http://www.ftdichip.com/FTDrivers.htm till Usb-adaptern. Öppnade den och konstaterade att det var ett FT232RL chip inuti.

Byglade RD och TD i usbadapterns DB9:a och kontrollerade sen med BrayTerm att jag fick echo på det jag skickade, vilket fungerade.

Lödde om DB9:an som jag lödde fel igår och provade igen. Bingo! Fick kontakt, men sen visade det sig efter lite snack med Emil att jag hade fel MT version så nåt mer blev inte gjort idag. Ska försöka ta mig till garaget under veckan och kontrollera att det funkar som det ska. Jag fick nämligen ingen kontakt med Communication testet i MT.

_________________
Projektet | Memberspage på vems.hu


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: tor aug 07, 2008 7:23 am 
Offline
Forumsberoende
Användarvisningsbild

Blev medlem: fre jun 30, 2006 5:25 pm
Inlägg: 750
Ort: Sjulsmark
Med Megatune 1.0.73Final så fick jag kontakt och problemet är alltså löst.

Såhär ska kabeln se ut:

Bild

_________________
Projektet | Memberspage på vems.hu


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Ny tråd Svara på tråd  [ 5 inlägg ] 

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 0 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori

Sök efter:
Hoppa till:  
POWERED_BY
Swedish translation by Peetra & phpBB Sweden © 2006-2010