Maxxecu GPO skillnader?

Insprutning, Tändsystem och Elektronik

Moderator: backeliten

ViperCobra
Lite mer laddtryck
Inlägg: 18
Blev medlem: tor maj 13, 2021 8:21 pm

Maxxecu GPO skillnader?

Inlägg av ViperCobra »

Hej alla och god fortsättning!
Kopplade in min varvräknare och hastighetsmätare i mellandagarna.
Varvräknaren in på GPO 8 (tach output) testkörde den via Maxxecu testfunktion och kalibrerade in den. Funkade klockrent.

Kopplade sen en 12v digital givare (tre ledare med separat utsignal) monterad på framhjulets ABS-ring, till DIN 1 och konfigurerade denna som ”speed sensor drive shaft”.
Kalibrerade sen in ”inputshaft speed sensor” så att det stämde mot min setup på bilen.

Aktiverade därefter hastighetsmätare på GPO 4 och skulle göra samma testkörning som med varvräknaren men när jag testade detta så var hastighetsmätaren helt död.
Testade därför att köra varvräknaren från GPO4 och hastighetsmätaren från GPO8 vilket fungerade. När jag snurrade på hjulet så fungerade hastighetsmätaren med rätt skalning och allt verkar ok.
Nu när jag startar bilen för att testköra så går hastighetsmätaren upp till 40km i timmen och sen tillbaka till 0 utan att jag ens börjat rulla bilen, till och från, oregelbundet.

Funderar därför på följande:
- Är det någon mer skillnad på GPO4 och 8 än att outputen är 5A på 8an och 2A på 4an, som kan orsaka störningarna?
- Kan störningen filtreras bort genom att sänka ”update rate” eller liknande, hur isf?
- Kan någon ge en rimlig förklaring till varför hastighetsmätaren endast fungerade på GPO8 men inte GPO4 medans varvräknaren fungerar på båda?

Jag kör maxxecu sport.
Tacksam för input.
Mvh
Mattias
Allx
För mycket laddtryck
Inlägg: 144
Blev medlem: ons jul 06, 2016 8:43 pm
Ort: Västerås

Re: Maxxecu GPO skillnader?

Inlägg av Allx »

GPO drar till jord förutom 8an som även har Pull-Up inbyggt och kan då användas till varvräknare. Du får bygga en egen extern Pull-Up mot 4an om du vill köra den.
ViperCobra
Lite mer laddtryck
Inlägg: 18
Blev medlem: tor maj 13, 2021 8:21 pm

Re: Maxxecu GPO skillnader?

Inlägg av ViperCobra »

Tack för din input Alix.
Jag tänkte mig att DIN 1 har pullup.
Mätarna funkar ju när jag kör hastighetsmätaren på GPO8 och varvräknaren på 4an. Det är störningen på hastighetsmätaren jag vill bli av med (och gärna förstå varför det funkar åt ena hållet men inte åt andra..).
Allx
För mycket laddtryck
Inlägg: 144
Blev medlem: ons jul 06, 2016 8:43 pm
Ort: Västerås

Re: Maxxecu GPO skillnader?

Inlägg av Allx »

Att varvräknaren fungerar på 4an låter konstigt men det blir väl någon backspänning eller att varvräknaren är så känslig att den lyckas läsa av små strömpulser. När du väljer varvräknare ut på gpo 8 aktiverar den pull-up automatiskt på antigen 5 eller 12 volt. Väljer du varvräknare på någon annan gpo står det vid output voltage att detta enbart gäller gpo 8. Att du lyckas få varvräknare att fungera både utan och med pull-up låter väldigt konstigt
ViperCobra
Lite mer laddtryck
Inlägg: 18
Blev medlem: tor maj 13, 2021 8:21 pm

Re: Maxxecu GPO skillnader?

Inlägg av ViperCobra »

Ska ta tag i bygget igen och försöka få klart det sista inför besiktningen av cobran.
Kvar på listan är hastighetsmätaren.
Alix föreslog bygga en pullup. Finns det någon bra beskrivning på detta? Jag tänker mig att jag kopplar +12v mot ett motstånd som i sin tur går till GPO4. Där nånstans T-kopplar jag detta mot hastighetsmätarens ingång…?
Någon som har en skiss på detta? Hade även varit intressant att få ett förslag på ”lagom” motstånd… typ 10kohm kanske.
ViperCobra
Lite mer laddtryck
Inlägg: 18
Blev medlem: tor maj 13, 2021 8:21 pm

Re: Maxxecu GPO skillnader?

Inlägg av ViperCobra »

Testade mig fram och det verkar som jag fått en funktion. Gjorde ungefär som jag skriver ovan. Mätaren går att testköra och det ser ut att funka klockrent När jag startar motorn så börjar mätaren fladdra. Kan generator/laddning orsaka störningar.. Men då borde ju iofs varvräknaren med fladdra, eller..?
Användarvisningsbild
mattias
Admin
Inlägg: 10046
Blev medlem: ons okt 22, 2003 10:25 pm
Ort: Sävar
Kontakt:

Re: Maxxecu GPO skillnader?

Inlägg av mattias »

Om du inte har någon pull-up mot +5 eller +12V så kommer ingången på hastighetsmätaren att "flyta" på okänd spänning. När givaren ser en tand så jordas ingången ner via givaren, om mätaren då ska se en signal måste ingången över en viss spänning omedelbart efter givaren släpper jord. När du inte har en pull-up är det inte något som bestämmer att det ska hända, så med viss magi och störningar kan det fungera ibland eller inte alls. Så installera en pull-up.
Enkelt förklarat. Kabeln som går från GPO4 (utgång för hastighetsmätar-signal) och går till mätaren, någonstans på den kabeln där det är bekvämt skarvar du in en kabel som med ett motstånd ansluter mot +5V eller +12V (beroende på vad mätaren vill ha, prova +5V först).
Mattias Säfsten (fd Sandgren)
Säljer, installerar, mappar och justerar motor-styrsystem och tillbehör.
Återförsäljare för MaxxECU, Link, ECU Master, VEMS, m.fl.
Nav-dyno och motor-bänk i Sävar vid E4.
Säljer, flödestestar och tvättar bränsle-spridare.
Skicka mail, PM eller ring vid intresse. Innehar F-skatt. Jobbar mest i norr.
Skriv svar